Jump to content

lastest version of TS need to roll back to version 3.3.2

This announcement is no longer active

A/LCpl Rabbit

All of you who have upgraded to the lastest version of TS need to roll back to version 3.3.2. As with MODS do not upgrade your TS without notification from us. You will not be allowed to join the server without the correct version on Sunday.

×
×
  • Create New...